ERP Senior X– Códigos Postais – 403 - Acesso negado. Você não possui permissão para acessar este conteúdo
Incidente
No módulo de Cadastros do ERP Senior X, ao tentar acessar o menu de códigos postais e tentar adicionar ou editar um código postal, é apresentada a mensagem: 403 - Acesso negado. Você não possui permissão para acessar este conteúdo
Causa
Esta mensagem é apresentada, pois o papel ao qual o usuário está vinculado não tem permissão a todos os recursos.
Solução
Para que a mensagem não seja apresentada ao tentar acessar o menu, realize os passos a seguir:
1. Com um usuário que tenha permissão para alterações de usuários, acesse ao menu Tecnologia / Administração / Autorização / Gestão dos Papéis;
2. Selecione o papel que esteja vinculado com o usuário com problema, e clique em Editar:
3. Acesse na aba Permissões e depois em agrupar por Recurso;
4. Filtre pelo seguinte recurso: res://senior.com.br/custom/report_database_metadata/platform-localization_v_city;
5. Selecione o recurso e clique no checkbox 'Visualizar':
6. Filtre em seguida por: res://senior.com.br/custom/report_database_metadata/platform-localization_v_postal_code;
7. Selecione o recurso e clique no checkbox 'Visualizar':
8. Filtre em seguida por: res://senior.com.br/custom/report_database_metadata/platform-localization_v_state
9. Selecione o recurso e clique no checkbox 'Visualizar':
10. Filtre em seguida por: res://senior.com.br/platform/localization/entities/city;
11. Selecione o recurso e aplique as permissões conforme sua necessidade:
12. Filtre em seguida por: res://senior.com.br/platform/localization/entities/country;
13. Selecione o recurso e aplique as permissões conforme sua necessidade:
14. Filtre em seguida por: res://senior.com.br/platform/localization/entities/postalCode;
15. Selecione o recurso e aplique as permissões conforme sua necessidade:
16. Filtre em seguida por: res://senior.com.br/platform/localization/entities/state;
17. Selecione o recurso e aplique as permissões conforme sua necessidade:
18. Filtre em seguida por: res://senior.com.br/platform/localization/postal-code-dataset;
19. Selecione o recurso e clique no checkbox 'Visualizar':
20. Salve o cadastro do papel;
21. Solicite ao usuário que faça o logoff e login no sistema;
22. Solicite ao usuário que teste novamente o acesso à tela.