ERP - Recebimento Eletrônico - Não foram encontrados registros cadastrados na configuração de leiaute selecionada. Empresa: XX; Código da configuração do leiaute: XX; Tipo de documento: XX; Versão do documento: XX
Incidente
Ao executar o processo de Recebimento Eletrônico de documentos a partir do eDocs, independente de qual seja a forma de integração (via WebService do eDocs ou WebService do ERP), ocorre a mensagem de erro a o documento não é integrado: Não foram encontrados registros cadastrados na configuração de leiaute selecionada. Empresa: XX; Código da configuração do leiaute: XX; Tipo de documento: XX; Versão do documento: XX.
Observação
A mensagem pode ocorrer também ao efetuar o Download do documento via Chave de Acesso na tela NF000INE_SRNF - Suprimentos / Gestão de Recebimento / Notas Fiscais de Entrada / Via Recebimento de Documento Eletrônico
Causa
Essa situação ocorre porque existe um leiaute inválido/em branco cadastrado na tela F017LRE - Cadastros / Mercado e Suprimentos / Recebimento Eletrônico / Configuração de leiaute.
Solução
Para solucionará este problema, execute os passos abaixo:
1. Acesse a tela F017LRE - Cadastros / Mercado e Suprimentos / Recebimento Eletrônico / Configuração de leiaute;
2. Selecione o leiaute que está mencionado na mensagem de erro de retorno;
3. Efetue o ajuste no leiaute, adicionando adequadamente os dados ou exclua o leiaute (caso ele realmente não deva estar cadastrado).
4. Acesse o monitor do eDocs e solicite o reenvio do retorno dos documentos que tiverm o registro de erro de retorno pelo motivo citado.
Importante
- Caso o retorno do eDocs para o ERP seja via WebService do ERP, nos próximos fluxos de integração o eDocs enviará o documento ao ERP;
- Caso o retorno do eDocs para o ERP seja via WebService do eDocs, o retorno ocorrerá través da execução do processo agendado de rotina 102 ou ainda poderá ser efetuado o processo manual através da tela NF000FRE - Recursos / Importar documentos e retornos do eDocs (Importação de documentos e retornos do eDocs).