ERP Senior X – Analytics – Sem permissão para este dataset
Incidente
Nos Analytics do ERP Senior X, ao acessar algum relatório, é apresentada a mensagem: Sem permissão para este dataset.
Causa
Esta mensagem é apresentada, pois está faltando permissão no papel vinculado ao usuário que está tentando realizar o processo.
Solução
Para que a mensagem não seja apresentada ao acessar o relatório no Analytics, realize os passos a seguir:
1. Acesse o menu Tecnologia / Customização / Páginas / Gerenciar;
Observação
Recomendamos esse passo a passo apenas se for um único Analytcs que está apresentado essa mensagem, se forem mais que um orientamos que siga para o passo 3.
1.1. Clique no botão Ações / Permissões do Analytics que apresentou a mensagem:
1.2. Abra o dataset e o analytic para copiar os recursos correspondentes ao analytics que está acusando que não tem permissão e anote;
2. Acesse o menu Tecnologia / Administração / Autorização / Gestão dos Papéis com um um usuário que tenha permissão para alterações de usuários;
Observação
Para maiores informações sobre como identificar os papéis atribuídos a um usuário, verifique o artigo: ERP Senior X – Gestão dos Usuários – Como identificar os papéis atribuídos a um usuário.
2.1. Selecione o papel que esteja vinculado com o usuário com problema, e clique em Editar;
2.2. Acesse na aba Permissões e depois em agrupar por Recurso;
2.3. Filtre pelo recurso copiado no passo 1.2:
2.4. Aplique as permissões para o papel;
2.5. Clique no botão Salvar;
2.6. Repita o passo 2.3, 2.4 e 2.5 para liberar o dataset e o analytic que são recursos diferentes. Aguarde alguns minutos e teste novamente o analytics;
3. Clique na guia Serviço em agrupar por Recurso no papel vinculado ao usuário. Esse procedimento é recomendado caso sejam vários analytics que estão apresentando a mensagem e queira liberar todos de uma só vez;
3.1. Filtre por custom / analytic;
3.2. Aplique as permissões desejadas nestes serviços:
3.3. Clique no botão Salvar;
3.4. Filtre por custom / dataset;
3.5. Aplique as permissões:
3.6. Clique no botão Salvar;
3.7. Tente acessar novamente o analytcs.
Observação
- A alteração pode levar alguns minutos até ter efeito no servidor da aplicação. Portanto, caso não surta efeito imediato, tente novamente após alguns minutos (não mais que 30 minutos).
- Clique aqui para acessar a documentação do Analytics e consulte liberar as permissões necessárias.
- Os prints acima são apenas para fins de facilitar o entendimento, mas a solução pode ser aplicada a todos os analytics disponíveis no sistema.