WMS SILT - Expedição - Impressoras não são listadas no coletor de dados
Incidente
No modulo de expedição, no fluxo do packing, as impressoras não aparecem listadas para poder selecionar e imprimir.
Causa
Este incidente ocorre, pois o serviço do Agente de Impressão não conseguiu localizar as impressoras pelo Agente de Impressão.
Solução
Para que este não ocorra é necessário regularizar o Agente de Impressão. Para isso realize os passos a seguir:
Atenção: Este processo envolve o reinício do Tomcat então o cliente precisa estar avisado sobre a parada da aplicação.
1. Solicite ao cliente que pare o serviço do Agente de impressão;
Atenção: é necessário que a ação seja feito pelo usuário administrador da máquina. A ação de reiniciar a máquina pode não subir o serviço conforme esperado.
2. Acesse o menu Configuração / Configuração Geral;
2.1. Selecione o proprietário que deseja alterar;
2.2 Clique no botão Alterar;
2.3 Clique no sub menu Impressão Remota;
2.4. No combo box 'Tipo Impressão Utilizada', marque a opção 'Impressão Local';
2.5. Clique no botão Salvar:
3. Espere 5 minutos para subir o novo tipo de impressão;
4. Acesse o servidor da aplicação do WMS e pare o servido Tomcat;
5. Inicie o serviço Tomcat;
6. Realize o mesmo processo do item 2 alterando o combo box 'Tipo Impressão Utilizada' para a opção 'Impressão por Mensageria';
7. Espere 5 minutos para subir o novo tipo de impressão;
8. Solicite ao cliente que inicie os serviços do Agente de Impressão.
Importante: antes de verificar se as impressoras foram listadas no coletor de dados, é necessário aguardar 5 minutos para que todos os serviços foram iniciados conforme esperado.
Observação: Para maiores informações sobre este incidente, consulte o artigo: WMS SILT - Agente de Impressão - As impressoras não estão sendo listadas no coletor de dados (Índice).