ERP Senior X – Recebimento Eletrônico – Não foi possível acessar o serviço do eDocs
Incidente
No módulo Tecnologia do ERP Senior X, ao verificar o agendamento responsável pelo recebimento eletrônico, está apresentando a seguinte mensagem: Não foi possível acessar o serviço do eDocs: The message with Action 'http://www.senior.com.br/nfe/IDownloadServico/ConsultarRetornoRecebimento' cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None).
Causa
Esta mensagem é apresentada, pois não está cadastrado o detalhamento de Documentos eletrônicos no cadastro da filial, ou a URL de comunicação está incorreta.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Acesse no menu em Cadastros / Filiais;
2. Filtre pela filial, selecione o registro e clique em Editar;
3. Nos detalhamentos de Documentos eletrônicos, na aba e-Docs, clique em Adicionar:
3.1. Informe os dados de comunicação com o eDocs e salve o cadastro:
4. Caso já exista o registro, clique em Editar;
4.1. Altere a URL para a correta e salve o cadastro. O padrão da URL segue conforme exemplo: https://SERVIDOR:8989/sde
Observação
O usuário e senha são os mesmos do eDocs, encontrados no menu em Configurações / Empresas, na aba Integração e campos do Web Service: