ERP – Processo de Cotação – Porque ocorrem pulos de códigos na numeração de processos de Cotação
Dúvida
Porque ocorrem pulos de códigos na numeração de processos de Cotação?
Causa
Essa situação pode ocorrer, quando um usuário indevidamente, informa um código maior do que deveria, e grava o registro.
A partir disso, todos os processos sugeridos vão buscar o último processo de cotação gerado, para buscar o próximo número.
Solução
Para contornar essa situação, realize os passos a seguir:
1. Acesse a tela F191CPT - Cadastros / Empresas / Parâmetros de Integração, e verifique se há integração com o Cotei:
2. Acesse a tela F070FCP - Cadastros / Filiais / Parâmetros por Gestão / Compras e Recebimento (Parâmetros da Filial para Compras);
3. Altere o parâmetro Tipo Busca Número Cotações para 'T' Buscar número livre em todos os processos', para que sejam buscados numerações inferiores que não foram utilizadas, ou então altere para 'N',Normal - Incremental a partir do último número, para que sejam utilizados os números de forma sequencial.
Importante
Deve ser validado internamente pelo cliente como deseja que a configuração seja realizada.
Atenção
Lembrando que se houver integração com o Cotei, sempre será sugerido o último número, após o maior número da tabela E410PCT.