ERP – Geração Nota de Entrada - Erro - Nota Fiscal de Entrada XX Série XX, Fornecedor XX, Filial X - 1.E501TCP: Erro de acesso ao banco de dados: Não foi encontrado o Registro-Mestre para este Registro. E501TCP(CodEmp;CodPor) -> E039POR(CodEmp;CodPor)
Incidente
No módulo de Suprimentos, ao tentar fechar a nota na tela F440GNE ocorre a mensagem: Erro - Nota Fiscal de Entrada XX Série XX, Fornecedor XX, Filial X - 1.E501TCP: Erro de acesso ao banco de dados: Não foi encontrado o Registro-Mestre para este Registro. E501TCP(CodEmp;CodPor) -> E039POR(CodEmp;CodPor).
Causa
Essa mensagem é apresentada quando o sistema não consegue localizar o portador para poder gerar as parcelas da nota.
Solução
Para que a mensagem não seja mais apresentada, é necessário fazer um select na tabela de definições do fornecedor para ver se o campo CodPor está preenchido com alguma informação indevida, como 'N' ou um código de portador que não existe cadastrado no sistema, para isso, realize os procedimentos a seguir:
1. Acesse o aplicativo CBDS que fica na pasta Sapiens da instalação do ERP ou ERP GOUP;
2. No CBDS entre no menu Arquivo e em Conectar:
3. Será aberta a tela Seleção de Ambiente de execução, escolha o ambiente onde deseja conectar e clique no botão OK:
4. Em seguida ao pedir logon, informe na opção forma de logon, selecione Logon normal, e abaixo informe seu usuário e senha e clique em Ok:
5. Assim que conectar na base, acesse o menu Ferramentas e Editor SQL:
6. Monte o select com os dados da base do cliente, e substitua os campos do exemplo a seguir:
SELECT CODPOR FROM E095HFO WHERE CODEMP=XX AND CODFIL=XX AND CODFOR=XX
Observação
Caso tenha dúvida sobre o que é cada campo do select utilize o F8 no sistema e verifique as tabelas e campos:
Após executar o comando acima acesse a tela F095CAD - Cadastros / Clientes e Fornecedores / Fornecedores / Cadastro ou a tela F095HFO - Cadastros / Clientes e Fornecedores / Fornecedores / Definições/Histórico e informe um portador válido no campo Portador Padrão:
Importante
Essa situação é mais comum ocorrer quando houve a importação dos cadastros dos fornecedores para base do cliente ou foi feita alguma intervenção via banco de dados e o campo ficou com informação incorreta.