WMS WIS - Separação - Pedido não aparece em tela para cancelamento mesmo com o parâmetro Cancela Ped. c/Int. Enviada ativo
Incidente
No módulo Separação, ao tentar Cancelar um pedido o mesmo não aparece na tela de Cancelamento de Separação mesmo o parâmetro 'Cancela Ped. c/Int. Enviada ativo' estando ativo.
Causa
Este incidente ocorre, pois mesmo estando ativo o parâmetro 'Cancela Ped. c/Int. Enviado' a situação do pedido já está em 60 - Pedido Enviado ou seja, todo o processo está finalizado, com isso não será possível o cancelamento via Tela de Cancelamento de Separação.
Solução
Para tornar possível o cancelamento do pedido com situação 60 - Pedido Enviado, realize os passos a seguir:
1. Certifique-se da existência da Interface no ERP referente a Integração de Pedido, cuja situação seja 2 e 4, caso ainda não exista é necessário a criação das mesmas no ERP, para que, no ato do cancelamento do pedido no ERP haja o envio das interfaces ao WMS;
2. Envie através do ERP a Interface (pedido) para o WMS com a situação 4 - Cancelar NF, será removida a Nota fiscal do pedido;
3. Envie a Interface do Pedido com a Situação 2 - Cancelar Pedido, daí será cancelado automaticamente o Pedido no WMS e gerado os dados para Armazenagem de Corte (retorno dos produtos para o estoque);
Observação: Acesse aqui o passo a passo de como validar a situação do pedido