ERP Senior X – Cadastros – Ocorreu um erro na requisição do dataset
Andre Wruck
Atualizado
Incidente No módulo de Cadastros do ERP Senior X, ao tentar inserir ou pesquisar por CEP, é apresentada a mensagem: Ocorreu um erro na requisição do dataset.
Causa Esta mensagem é apresentada, pois está faltando permissão no papel vinculado ao usuário que está tentando realizar o processo.
Solução Para que a mensagem não seja apresentada ao inserir ou pesquisar por CEP, realize os passos a seguir:
1. Com um usuário que tenha permissão para alterações de usuários, acesse no menu Tecnologia em Administração / Autorização / Gestão dos Papéis; 2. Selecione o papel que esteja vinculado com o usuário com problema, e clique em Editar:
3. Acesse na aba Permissões e depois em agrupar por Recurso:
4. Filtre pelo seguinte: res://senior.com.br/erpx_fnd/starter/datasets ; 5. Selecione o recurso Dataset do ERPX Starter e clique no checkbox 'Visualizar':
6. Depois filtre pelo seguinte: res://senior.com.br/platform/localization ; 7. Em todos os recursos listados, marque a opção de 'Visualizar': Observação Caso o usuário deva ter permissão também para alterar dados das localizações, marque as opções 'Editar', 'Excluir' e 'Incluir', juntamente com a 'Visualizar'.
8. Salve o cadastro do papel; 9. Faça o logoff e após o login do usuário com problemas e tente fazer o processo novamente.
Importante A alteração pode levar alguns minutos até ter efeito no servidor da aplicação. Portanto, caso não surta efeito imediato, tente novamente após alguns minutos (não mais que 30 minutos).
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.
No módulo de Cadastros do ERP Senior X, ao tentar inserir ou pesquisar por CEP, é apresentada a mensagem: Ocorreu um erro na requisição do dataset.
Causa
Esta mensagem é apresentada, pois está faltando permissão no papel vinculado ao usuário que está tentando realizar o processo.
Solução
Para que a mensagem não seja apresentada ao inserir ou pesquisar por CEP, realize os passos a seguir:
1. Com um usuário que tenha permissão para alterações de usuários, acesse no menu Tecnologia em Administração / Autorização / Gestão dos Papéis;
2. Selecione o papel que esteja vinculado com o usuário com problema, e clique em Editar:
3. Acesse na aba Permissões e depois em agrupar por Recurso:
4. Filtre pelo seguinte: res://senior.com.br/erpx_fnd/starter/datasets ;
5. Selecione o recurso Dataset do ERPX Starter e clique no checkbox 'Visualizar':
6. Depois filtre pelo seguinte: res://senior.com.br/platform/localization ;
7. Em todos os recursos listados, marque a opção de 'Visualizar':
Observação
Caso o usuário deva ter permissão também para alterar dados das localizações, marque as opções 'Editar', 'Excluir' e 'Incluir', juntamente com a 'Visualizar'.
8. Salve o cadastro do papel;
9. Faça o logoff e após o login do usuário com problemas e tente fazer o processo novamente.
Importante
A alteração pode levar alguns minutos até ter efeito no servidor da aplicação. Portanto, caso não surta efeito imediato, tente novamente após alguns minutos (não mais que 30 minutos).
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.