ERP – Integração Cotei – Processo de cotação fica com o 'Status Integ. Cotei' como 'Finalizado' e com a observação definida como 'Processo finalizado'
Incidente
Ao realizar um processo de cotação que tenha integração com o Cotei via tela NF410PCT_SCCP - Suprimentos / Gestão de Compras / Cotação de Preço / Processo de Cotação / Cadastro (Processo de Cotação), o processo de cotação fica com o 'Status Integ. Cotei' como 'Finalizado' e com a observação definida como 'Processo finalizado'.
Observação
Também vinculado a esse cenário podem haver situações onde as informações dos fornecedores não seja recebida, e os valores apresentados na tela NF410QCP_SCCP - Suprimentos / Gestão de Compras / Cotação de Preço / Quadro comparativo de propostas (Quadro Comparativo de Propostas de Cotações), estejam zerados pela falta de retorno dos dados via integração.
Causa
Essa situação ocorre quando, o usuário realiza o fechamento manual de um processo de cotação, através do botão Liberar, sem que haja o retorno de todas as Cotações através do Cotei.
Solução
Importante
Sempre valide se o processo automático está ocorrendo, antes de realizar qualquer ação que envolva integrações, para evitar por exemplo, que o processo de cotação seja finalizado sem envio aos Fornecedores, ou sem retorno dos mesmos.
Para que essa situação não ocorra, realize os passos abaixo:
1. Acesse a tela NF000AGE - Recursos / Processos Automáticos / Cadastro (Cadastro de Processo Automático), e na aba Rotina, informe o código do processo automático relacionado a integração Gestão Empresarial | ERP com Cotei;
1.1. Clique no botão Log, e de acordo com o tempo de execução do processo automático, verifique se ele foi executado com sucesso;
2. Acesse a tela F410PCT_SCCP - Suprimentos / Gestão de Compras / Cotação de Preço / Processo de Cotação / Cadastro e verifique se não há nenhum mensagem de crítica no campo Status de Integ. Cotei;
4. Verifique a pasta de logs de integração com o Cotei, se há indícios que a integração não está ocorrendo por algum motivo;
Observação
Caso você seja cliente de solução Cloud da Senior, e não possua acesso a pasta de Logs, acione a equipe de IT Services e solicite os arquivos de integração com Cotei. Exemplos de nome do log de integração:
- integracao_cotei_consultando_cotacoes_via_processo_13_01_2023_10_59_07;
- integracao_cotei_enviando_pendentes_via_processo_13_01_2023_10_59_08
5. Evite finalizar um processo de cotação pelo botão Liberar, caso seja verificado que o processo automático não está sendo executado;
6. Clique no botão Processar, caso deseje que o processo de cotação seja enviado e preenchido pelos fornecedores novamente, ou clique no botão Reabrir para que o processo de cotação seja reaberto.
Importante
Após qualquer ação de reabrir ou processar novamente um processo de cotação, será necessário que o processo automático seja executado para que ocorra a integração das informações.
Observação
Para maiores informações sobre o processo de integração entre Gestão Empresarial | ERP e Cotei, verifique o artigo ERP - Integração Cotei - Onde é possível encontrar informações diversas sobre processo de integração do Gestão Empresarial | ERP com Cotei (índice).