WMS SILT – Integração – O registro não pode ser inserido ou alterado, pois o código que identifica o registro já foi utilizado
Incidente
Na tela Configuração de Integração, ao tentar salvar uma configuração de arquivo, o sistema retorna a mensagem:
O registro não pode ser inserido ou alterado, pois o código que identifica o registro já foi utilizado. SILT_XX.UN_CONFIGINTE_DIRIMP.
Causa
Essa mensagem é apresentada, pois já existe um cadastro com o mesmo diretório configurado para a configuração de integração que está sendo alterada.
Solução
Para identificar o diretório já cadastrado no sistema, realize os passos a seguir:
1. Acesse o menu navegação Configuração / Configuração de Integração;
2. Selecione a integração que deseja alterar e clique no botão alterar;
3. Acesse o submenu Diretórios;
4. Copie a informação do campo Diretório de Importação;
5. Feche a tela de alteração;
6. Clique na coluna Diretório de Importação e cole a informação copiada no item 4.
Observação: Caso a integração seja REST e o caminho for em TomCat diferentes, é recomendado desabilitar a integração com TomCat inexistente.