ERP – Produtos e Serviços – Registro com o valor (XX) para o campo <Família> não existe na base ou está indisponível para este usuário
Incidente
Na rotina de Cadastros de Produtos de forma agrupada, via tela F075GFP - Cadastros / Produtos e Serviços / Produtos / Agrupado (Cadastro de Produtos - Agrupado), ao informar a família no cabeçalho da tela, é apresentada a mensagem: Registro com o valor (XX) para o campo <Família> não existe na base ou está indisponível para este usuário.
Causa
Essa mensagem ocorre porque ao menos uma das condições do comando abaixo, não foi atendida.
SELECT
_ /*+ FIRST_ROWS */ E012FAM.CODEMP "CODEMP", E012FAM.CODFAM "CODFAM", E012FAM.DESFAM "DESFAM", E012FAM.TIPPRO "TIPPRO", E012FAM.CODORI "CODORI"_
FROM
_ E012FAM_
WHERE
_ E012FAM.TIPPRO <> 'S' AND_
_ E012FAM.INDFRT <> 'S' AND_
_ E012FAM.CODEMP = 1 AND_
_ E012FAM.CODFAM = 'XX'_
ORDER BY
_ 1 ASC,2 ASC_
Solução
Para que a mensagem não seja apresentada, siga os passos:
1. Verifique a condição E012FAM.TIPPRO <> 'S' AND, o tipo de produto não pode ser Serviço;
1.1. Acesse a tela F083ORI - Cadastros / Produtos e Serviços / Origens / Cadastro (Origem de Produto), e para confirmar verifique a informação do campo Tipo de Produto;
2. Verifique a condição E012FAM.INDFRT <> 'S' AND, não pode ser indicativo de Ferramentas;
2.1. Acesse a tela F083ORI - Cadastros / Produtos e Serviços / Origens / Cadastro (Origem de Produto), e para confirmar verifique a informação do campo Ferramentas;
3. Verifique a condição E012FAM.CODFAM = 'XX', o cadastro da família tem que existir na Base;
3.2. Acesse a tela F012FAM - Cadastros / Produtos e Serviços / Famílias (Cadastro de Famílias), informe o código da família pra verificar se ela está devidamente cadastrada;
4. Avalie as condições acima, e após essa ação volte para o cadastro do produto para seguir com o processo conforme sua necessidade.