TECNOLOGIA – Conexão ODBC – Erro do Banco (12154): ORA-12154: TNS: não foi possível resolver o identificador de conexão especificado
Incidente
Ao realizar as configurações de acesso ODBC no SeniorConfigCenter para conexão ao banco de dados, e clicar no botão Testar Conexão, é apresentada a mensagem: Erro do Banco (12154): ORA-12154: TNS: não foi possível resolver o identificador de conexão especificado.
Causa
Essa situação pode ocorrer devido a algumas situações, uma delas é que a variável de ambiente TNS_ADMIN que não possui o caminho onde está o arquivo tnsnames.ora.
Solução
Para que a mensagem não seja mais apresentada caso seja relacionada a variável de ambiente TNS_ADMIN, siga os passos abaixo:
1. Verifique o caminho correto do arquivo tnsnames.ora na sua máquina;
2. Digite, no menu Iniciar do Windows a palavra variáveis, e clique na opção Editar as variáveis de ambiente do sistema;
3. Clique no botão Variáveis de Ambiente;
4. Observe se a variável TNS_ADMIN está constando nas variáveis do sistema;
5. Avalie se o caminho da variável TNS_ADMIN está coerente com o local onde está o arquivo tnsnames.ora;
6. Altere o caminho, caso não estiver apontando para o mesmo local do arquivo tnsnames.ora;
6.1. Selecione a variável e clique no botão Editar;
6.2. Informe o caminho onde se encontra o arquivo tnsnames.ora, depois clique no botão OK;
6.3. Clique no botão OK na tela das Variáveis do Sistema e depois na tela Propriedade do Sistema;
7. Reinicie o seu computador;
8. Volte para o SeniorConfigCenter.exe e clique novamente no botão Testar Conexão, para validar que a mensagem não será mais apresentada.