TECNOLOGIA - RabbitMQ - Porta não inicia ao iniciar o serviço do Windows
Incidente
Ao iniciar o serviço do RabbitMQ no Windows, o serviço fica com status Em execução, porém a porta do RabbitMQ não é iniciada.
Causa
Essa situação ocorre, pois algo na infraestrutura está bloqueando a porta SSL no servidor.
Solução
Para que este incidente não ocorra, siga os passos a seguir:
1. Pare o serviço do RabbitMQ;
2. Acesse o diretório C:\Users\USUARIO\AppData\Roaming\RabbitMQ\;
2.1. Em USUARIO informe o usuário em que foi instalado o RabbitMQ, geralmente no usuário configurado no serviço;
3. Edite o arquivo rabbitmq.conf, com um editor de texto;
4. Localize o parâmetro ssl, conforme exemplo abaixo:
5. Altere o valor do ssl para false e salve o arquivo;
6. Inicie o serviço do RabbitMQ.
Caso a porta inicie com o parâmetro ssl = false, significa que algo na infraestrutura está bloqueando o inicializar da porta ssl no servidor.
Caso precise de apoio na análise da infraestrutura, é possível a contratação de consultoria de TI para apoio.
Contate o seu executivo de contas para essa alocação.
Observação:
Análise de infraestrutura não é coberto pelo suporte ou manutenção dos produtos Senior.