ERP - Configuração de Pesquisa de Tela - Campos Disponíveis não estão sendo atribuído a caixa Campos Selecionados na tela de Configuração de Pesquisa.
Incidente
Alguns campos específicos que estão na caixa de Campos Disponíveis não estão sendo atribuído a caixa Campos Selecionados na tela de Configuração de Pesquisa.
Exemplo:
Em alguma tela do ERP ao clicar na lupa de pesquisa, abre a Pesquisa de Registro.
Depois ao clicar em configurar selecionar um campo e atribuí-lo para Campos Selecionas e clicar em OK
Mesmo após esse processo, ao clicar na Lupa o campo não estava disponível na Grid
Causa
Esta situação ocorre, pois foi selecionado pelo usuário, a opção 'Salvar' por tela de Origem na tela de pesquisa de registro.
Solução
Para que os campos fiquem disponíveis nos campos selecionados da tela de configuração de Pesquise, realize os passos do exemplo a seguir:
1. Acesse a tela em questão onde está sendo feita a consulta;
Observação
Para este caso vamos utilizar o exemplo da tela F435CCC_SREB - Suprimentos / Gestão de Recebimento / Entrada via Balança / Via Contrato com Classificação.
2. Abra a tela e clique na Lupa do campo Fornec.:

Importante
Será aberta a tela de Pesquisa de Registro.

3. Clique na aba Salvar:

Atenção
4. Marque a opção 'Padrão' e a opção 'Restaurar Padrão' e desmarque as demais opções, caso alguma esteja marcada;
5. Clique no botão Configurar:

4. Selecione o campo e depois direcione o mesmo para os "Campos Selecionados":

5. Clique no botão OK;
6. Ajuste o campo como desejado e observe se o resultado é o campo ser mostrado na pesquisa a partir desse procedimento.