ERP – Inicialização do sistema ERP – Ocorreu um erro na sincronização de usuários: Registro de novos usuários : Violação de chave
Incidente
Ao tentar logar no sistema é apresentada a seguinte mensagem: Ocorreu um erro na sincronização de usuários: Registro de novos usuários : Violação de chave
Causa
Essa mensagem pode ocorrer em algumas situações. Uma das situações mapeadas há um registro indevido com o valor '0' (Zero) no cadastro de empresas na tabela E070EMP.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Acesse a ferramenta CBDS, ou outra ferramenta que seja possível ter acesso ao banco de dados, através da pasta Sapiens, dentro pasta de instalação do sistema;
2. Execute o comando abaixo para verificar se há alguma empresa cadastrada com o código '0-Zero';
SELECT E070EMP.CODEMP AS CODEMP, E070EMP.CPRFOC AS CPRFOC, E070EMP.CPRFCP AS CPRFCP, R999USU.CODUSU AS CODUSU, R999USU.NOMUSU AS NOMUSU, R900CPL.EMAIL FROM E070EMP, R999USU, R900CPL WHERE R999USU.CODUSU = R900CPL.PERID AND NOT EXISTS ( SELECT 1 FROM E099USU WHERE E099USU.CODUSU = R999USU.CODUSU AND E099USU.CODEMP = E070EMP.CODEMP)
Observação
Este comando apresenta se há diferença entre as tabelas.
3. Valide através do SQLMON clicar para abrir o sistema para verificar o último comando antes de apresentar a mensagem, ou um comando que pode estar gerando a mensagem;
4. Acione o seu DBA para gerar um trace do banco e verificar o último comando, caso o SQLMON ou o sistema trave e não seja possível obter a informação através do SQLMON.
Importante
- Podem haver sujeiras de cadastros de usuários já excluídos dentro de tabelas que o sistema não está encontrando valores de chaves primárias;
- Identifique a tabela e verifique se os dados dentro desta tabela estão devidamente vinculados à outras tabelas dentro do banco de dados e, caso você constate que não estão e são somente sujeiras realmente, efetuar a exclusão destes dados.