RONDA – Instalação Ronda Senior – Falha ao instalar .Net 3.5 de forma automatizada durante instalação do Ronda
Incidente
Durante o processo de instalação do Ronda Senior utilizando o Senior Installer, ao tentar criar o serviço da CSM Center ou qualquer outro serviço do Glassfish, é solicitado instalar o .Net 3.5 de forma automatizada, mas esta instalação falha pouco depois de começar, indicando código de erro geralmente atribuído a problemas de conexão com o Windows Update. No caso da instalação da CSM Center, o instalador não permite continuar o processo sem a criação do serviço.
Causa
Isso ocorre devido ao fato de que Sistemas Operacionais mais recentes não possuem o .Net 3.5 instalado por padrão e ocorre falha ao tentar utilizar o Windows Update para adicionar esse recurso ao Sistema.
Solução
Para instalar o .Net 3.5 de forma manual, siga as instruções a seguir
1. Baixe a ferramenta de criação de mídia da Microsoft, disponível no site oficial da Microsoft;
2. Clique para expandir a sessão Como usar a ferramenta para criar mídia de instalação (pen drive, DVD ou arquivo ISO) para instalar o Windows 10 em um computador diferente:
3. Execute os passos de 1 a 5 para baixar a ISO do Windows 10 Pro:
4. Clique duas vezes no arquivo ISO baixado para que seja montado como uma "unidade de DVD":
5. Abra o Prompt de Comando como Administrador:
6. Execute o seguinte comando: dism /online /enable-feature /featurename:NetFX3/All /Source:D:/sources/sxs /LimitAccess;
Observação: Caso a letra da unidade montada não seja D, altere a letra após o /source, para a letra correspondente;
7. Reinicie o computador para aplicar a alteração