ERP – WebServices – Situação do cliente não fica conforme enviado na requisição ao utilizar o webservice Com.senior.g5.co.ger.cad.clientes
Incidente
No módulo de cadastros, ao tentar integrar as informações dos clientes, a situação do cliente não fica conforme enviado na requisição ao utilizar o webservice Com.senior.g5.co.ger.cad.clientes.
Causa
Esta situação ocorre devido aos Parâmetros de Integração do grupo Cliente da tela F191CPT.
Solução
Para que a situação do cliente fique conforme enviado na requisição ao realizar o cadastro de clientes via integração, realize os passos a seguir:
1. Acesse a tela F191CPT - Cadastros / Empresas / Parâmetros de Integração e selecione o Grupo 'Cliente';
2. Verifique como está o parâmetro Manter cliente ativo no ERP quando inativo na SEFAZ. As opções disponíveis são:
Observação:
Quando o sistema está parametrizado para se comunicar com a SEFAZ (Acesse aqui a documentação referente este processo), ao cadastrar um cliente via Web Service, mesmo que seja enviado o campo para ele ser inserido como 'I'-Inativo, por exemplo, caso ele estiver com o cadastro ativo na SEFAZ ele sempre irá ser criado no ERP como ativo, pois não existe parâmetro para desabilitar esse processo.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.