ERP – Cadastro Clientes – Saltos em códigos de clientes/fornecedores quando são utilizados Web Services de cadastro.
Incidente
Ao utilizar algum WebServices de cadastro de cliente/fornecedor para integrar registros no ERP, quando ocorre alguma crítica de integração do registro, o sistema ERP altera o código do último cliente/fornecedor utilizado na tabela E078ULT, mesmo que o cadastro não seja integrado, gerando pulos de numeração de cadastros de clientes.
Causa
Essa situação ocorre devido ao comportamento padrão da integração por serviço para evitar o lock na tabela E078ULT, e por consequência o enfileiramento das integrações.
Importante
A situação reportada já foi avaliada anteriormente pela nossa área de manutenção. Seguem abaixo informações sobre a análise que foi efetuada sobre a alteração do valor do último código da tabela E078ULT em relação a integração de cadastros via Web Service.
Observação
Exemplo explicativo:
Caso quiséssemos Reaproveitar a numeração, cada processamento de uma integração do cliente deve ser único de forma que se inicie, busque o código, faça todo o processamento, grave e atualize o número ou, em caso de erro volte atrás.
Em um ambiente integrado com várias requisições simultâneas estaríamos enfileirando todas as requisições para que aguardassem sempre o retorno da primeira requisição para prosseguir com a próxima, fazendo com que o tempo de retorno da requisição fique grande, o que pode gerar problemas de timeout ou problemas de falta de instâncias para processar outras requisições.
O código gerado é de responsabilidade do sistema então ele pode ou não pular alguns números e isso não causa nenhum problema posterior na operação do sistema.
Atenção
É importante salientar ainda que:
- A situação já foi avaliada anteriormente e não serão efetuadas alterações neste conceito;
- Integração via WebServices não são indicadas para importação de um grande número de cadastros (exemplo: uma carga de dados de um sistema de legado). Neste caso, orienta-se a utilização de leiautes de importação.
- Para mais informações sobre salto em código de clientes, verifique o artigo: ERP – Clientes – Código de cliente saltando numeração sequencial;
- Para mais informações sobre sequência de numeração de Fornecedor/Cliente/Representante/Transportadora, verifique o artigo: ERP – Cadastros – Como utilizar a sequência correta caso a numeração do código do Fornecedor/Cliente/Representante/Transportadora esteja fora da sequência padrão;
- Para mais informações sobre saltos em numerações de cadastros de Cliente/Fornecedor/Representante/Transportadora, verifique o artigo: ERP - Cadastros - Como parametrizar o sistema para que não seja possível saltar/pular a sequência dos cadastros de Cliente/Fornecedor/Representante/Transportadora.