TECNOLOGIA – Glassfish – Não foi possível se autenticar no servidor Java EE. Verifique se o servidor está inicializado ou se há um software firewall instalado
Incidente
Ao atualizar/instalar o sistema é apresentada a mensagem: Não foi possível se autenticar no servidor Java EE. Verifique se o servidor está inicializado ou se há um software firewall instalado
Causa
Esta mensagem é apresentada, pois o atualizador/instalador não conseguiu se conectar com a porta admin do Glassfish.
Solução
Para que a mensagem não seja apresentada ao atualizar/instalar o sistema, verifique os itens a seguir:
1. Verifique o usuário/senha que está sendo informado é o do Glassfish, por padrão o usuário é admin e a senha adminadmin ;
2. Verifique se o serviço do Glassfish está iniciado;
3. Reinicie o serviço do Glassfish;
4. Verifique se os parâmetros do Glassfish estão corretos; Clique aqui para acessar a documentação de configuração dos parâmetros do Glassfish.
4.1 Requer reinicio do Glassifsh se alterado.
5. Verifique se está habilitado o Secure-Admin no Glassfish; Clique aqui para acessar a documentação para habilitar o Secure-Admin no Glassfish.
5.1 Requer reinicio do Glassifsh se alterado.
6. Verifique a versão da JDK utilizada, para a OpenJDK 1.8 foi testado até a build 282;
6.1 Requer reinicio do Glassifsh se alterado.
7. Verifique se JDK está apontada no arquivo asenv.bat localizado em <glassfish>\glassfish\bin pelo parâmetro 'set AS_JAVA';
7.1 Requer reinicio do Glassifsh se alterado.
8. Verifique se o Firewall do Windows não está bloqueando a porta.