TECNOLOGIA – Configuração dos Campos da Grid – Campos não ficam na ordem desejada em várias rotinas do ERP
Incidente
Campos não ficam na ordem desejada em várias rotinas/módulos do ERP.
Algumas situações reportadas:
- Ao tentar arrastar um campo para uma outra nova posição, não fica gravado por muito tempo e o campo logo volta para sua posição anterior;
- Ao tentar mover um campo para sua posição original, pois o campo estava fora da posição original, o campo não volta para a posição original, o sistema não grava;
Causa
Essas situações ocorrem respectivamente porque:
- Usuários podem ter alterado a configuração dos campos da grid, quando isso é permitido, e ter marcado o check box 'Salvo Para Todos' , e assim automaticamente alterou para aquele que antes mostrava corretamente;
- Usuários removem o campo da grid, através de algum opção de seleção de campos, e ao atribuir novamente o campo a tela, o campo fica fora da sequência padrão;
Observação
Nesse último caso, há rotinas que não permitir alteração de campos na grid, por isso devem validar a segunda solução que será descrita abaixo
Solução
Para que os usuários não possuam permissão para realizar essa alteração como Todos, realize os passos a seguir:
1. Acesse o menu Recursos / Configurações / Usuários / Configuração Telas;
1.1. Selecione a opção Configuração de Grids;
1.2. Clique no botão Segurança:
1.3. Selecione o usuário ou grupo e clique no botão Detalhes:
1.4. Remova a permissão de usuários ou grupos, por desmarcar a opção Salvar Todos:
1.5. Clique no botão OK, nas duas telas.
Importante
Após esse procedimento, os usuário ou grupos selecionados, somente conseguirão salvar como individual ou padrão.
Lembrando que se o usuário ou grupo possui a a permissão de salvar como padrão, o mesmo poderá definir um novo padrão para a configuração dos campos da tela onde realizar o procedimento.
Para que os campos da grid, possam voltar ao padrão original, realize os passos a seguir:
2. Acesse a tela e clique no botão C (Configuração dos Campos da Grid) ;
2.1. Marque o check box 'Padrão' e clique no botão Restaurar Original:
Observação
Após esta ação, os campos serão restaurados a suas posições originais definidas pelo ERP, e não mais de acordo com alguma configuração de usuários.