Tecnologia – Wildfly – AMQ222212: Disk Full! Blocking message production on address
Incidente
Ao tentar iniciar um dos multi-domínios do Wildfly, utilizando o ArtemisMQ, o domínio não é iniciado e são apresentadas as mensagens abaixo no log do Artemis:
- WARN [org.apache.activemq.artemis.core.server] AMQ222210: Free storage space is at 16,1GB of 160,9GB total. Usage rate is 90,0% which is beyond the configured <max-disk-usage>. System will start blocking producers.
- WARN [org.apache.activemq.artemis.core.server] AMQ222212: Disk Full! Blocking message production on address 'jms.topic.RONDAG6LongOperationCoordinator'. Clients will report blocked.
- WARN [org.apache.activemq.artemis.core.server] AMQ222212: Disk Full! Blocking message production on address 'jms.queue.RONDAG6Queue'. Clients will report blocked.
No log do Wildfly são apresentadas as seguintes mensagens:
- WARN [org.apache.activemq.artemis.core.client] (ServerService Thread Pool -- 116) AMQ212054: Destination address=jms.topic.RONDAG6AcertoTopic is blocked. If the system is configured to block make sure you consume messages on this configuration.
- WFLYCTL0348: Timeout after [300] seconds waiting for service container stability. Operation will roll back. Step that first updated the service container was 'add' at address '[("interface" => "management")]'.
- WARN [org.jboss.as.controller.management-operation] (Controller Boot Thread) WFLYCTL0496: Thread dump: ******************************************************************************* "main" Id=1 RUNNABLE (in native).
- WARN [org.apache.activemq.artemis.core.client] (ServerService Thread Pool -- 116) AMQ212054: Destination address=jms.topic.RONDAG6AcertoTopic is blocked. If the system is configured to block make sure you consume messages on this configuration.
- INFO [org.infinispan.CLUSTER] (thread-7,ejb,DC-<servidor>:domain1) [Context=gestaoponto.ear.g6-senior-message.jar.TimerCache.PERSISTENT].
- ISPN100010: Finished rebalance with members [DC-<servidor>:domain2, DC-<servidor>:domain4, DC-<servidor>:domain9, DC-<servidor>:domain3, DC-<servidor>:domain1, DC-<servidor>:domain5, DC-<servidor>:domain8]
Causa
Esta situação ocorre pois no arquivo broker.xml, do ArctiveMQ, está configurado o uso máximo de até 90% do espaço em disco. Essa configuração é padrão, portanto no momento em que o disco chega em 90% de uso, ele limita recursos necessários para o funcionamento do Artemis.
Solução
Para que essa situação seja resolvida, siga os passos abaixo:
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema e na infraestrutura.
Acesse o arquivo broker.xml:
1.1 Acesse o diretório Active_MQ \ bin \ ACTIVE_MQ \ etc;
1.2 Abra o arquivo broker.xml com um editor de texto.
- Localize o parâmetro <max-disk-usage>;
- Ajuste o valor de 90 para 100, conforme exemplo abaixo:

- Reinicie o serviço do ArctiveMQ Artemis.