Tecnologia - Wildfly/Webservices - Resolução de problema no consumer count das filas JMS do Wildfly
Incidente
No sistema Senior, as execuções de Webservice assíncronos não são executadas e não aparecem nos logs do Wildfly.
Causa
Isso ocorre por conta das requisições ficarem paradas na fila JMS do domínio, isso pode ocorrer quando o consumer count da fila JMS do produto está em 0:

Solução
Para resolver esse problema, realize os passos a seguir:
- Acesse a console administrativa do Wildfly, a URL padrão é http://localhost:9990/;
-
Na aba Configuration, acesse o profile utilizado pelo domínio no seguinte caminho:
Configuration / Profiles / "Profile do domínio" / Messaging / Server / Default
- Clique em "View" e acesse Pooled Connections;
- Nessa tela verifique o Conector que está sendo utilizado:
- No caso de estar sendo utilizado o Artemis, é necessário verificar se existe a necessidade de utilizar esse conector no ambiente, sendo este o caso, verifique a seguinte documentação para validar as configurações para utilização do mesmo:
- Caso não tenha necessidade de utilizar o conector Artemis, altere esse parâmetro para o "in-vm":

Será necessário alterar o conector nos seguintes caminhos também:
Connection Factory:

Após esses ajustes, reinicie o serviço do Wildfly por completo para que as alterações sejam aplicadas.