ERP – Cadastro de Clientes – Ao clicar na Lupa do campo Cliente como Fornecedor é apresentada a mensagem: Nenhum registro disponível para consulta
Incidente
No módulo de Cadastros, na tela F085CAD - Cadastros / Clientes e Fornecedores / Clientes / Cadastro (Cadastro de Clientes), ao clicar na Lupa do campo Cliente como Fornecedor é apresentada a mensagem: Nenhum registro disponível para consulta
Causa
Essa mensagem ocorre porque ao clicar na Lupa do campo Cliente como Fornecedor, o sistema busca um Fornecedor com o mesmo CNPJ do cadastro do cliente e que tenha código Fornecedor como Cliente zerado (0) ou igual a 1086, conforme a imagem explicativa acima.
Observação
Segue abaixo o comando que o sistema faz.
SELECT CODFOR "CODFOR" FROM E095FOR WHERE E095FOR.CGCCPF = 4845940000132 AND (E095FOR.CODCLI = 0 OR E095FOR.CODCLI = 1086) AND 0 = 0 ORDER BY 1 ASC
Atenção
Foi utilizado no comando o cliente 1086, conforme exemplo explicativo da base interna do Suporte ERP.
Nesse caso, o código do cliente para o campo E095FOR.CofCli, vai diferir em cada cenário.