ERP MEGA - Relatórios Mega Agro - Não foi possível emitir o relatório
⚠️ Atenção: Clientes Cloud não tem permissão para executar o processo descrito abaixo e devem solicitar suporte via Taskcenter.
Incidente
No Mega Agro, ao tentar gerar um relatório é apresentada a mensagem: Não foi possível emitir o relatório.
Causa
Esta mensagem é apresentada quando há erro em algum componente interno do relatório, por componentes internos desatualizados ou por relatórios desatualizados.
Solução
Para que a mensagem não seja apresentada ao gerar o relatório, realize os passos a seguir:
- Com o relatório aberto no Crystal Reports, clique em Arquivo;
- Clique em Informações Resumidas;
- Na tela de Propriedades de Documento, no campo Comentários, apague a palavra "Convertido"
- Clique em Ok;
- Verifique se o incidente foi corrigido. Caso o incidente continue ocorrendo, continue a partir do passo 6.
- Clique em Banco de Dados;
- Clique em "Verificar Banco de Dados";
- Verifique se o incidente foi corrigido. Caso o incidente continue ocorrendo, continue a partir do passo 9.
- Clique em Banco de Dados;
- Clique em "Definir Local da Fonte de Dados";
- Na tela aberta, vincule corretamente cada uma das fontes de dados do relatório com o banco de dados que deseja vincular ao relatório;
👉Utilize o símbolo de + e - para facilitar expandir/recolher as propriedades de cada item existente na área de Fonte de Dados Atual.
- Selecione a fonte atual na área de Fonte de Dados Atual e selecione a fonte correta a ser vinculada na lista de fontes da área Substituir por;
- Clique em Atualizar.
- Repita o processo do passo 9 ao 13 para cada uma das fonte de dados que precisarem da vinculação correta;
- Clique em Fechar.
- Ao finalizar as vinculações, salve o relatório e o execute novamente.