ERP – Cadastros – Faltou informar se o Roteiro liga no Produto ou na Derivação
Incidente
No módulo de Cadastros, na tela F080SER - Cadastros / Produtos e Serviços / Serviços / Individual (Cadastro de Serviços), ao alterar uma informação de serviço, é apresentada a mensagem: Faltou informar se o Roteiro liga no Produto ou na Derivação.
Causa
Essa mensagem é apresentada, pois os campos E012FAM.RotPro e E075PRO.RotPro estão divergentes, ou seja, o campo da tabela E012FAM está como S-Sim, mas o da tabela E075PRO está como nulo.
Solução
Para que a mensagem não seja apresentada, ao alterar informação de um serviço, realize os passos a seguir:
1. Acesse a ferramenta CBDS, ou outra ferramenta que seja possível ter acesso ao banco de dados, através da pasta Sapiens, dentro pasta de instalação do sistema;
1.1. Acesse o ambiente Cloud se você utilizar a solução Cloud, e abra a ferramenta CBDS;
Observação
Caso você seja cliente de solução Cloud da Senior, e não possua acesso a ferramenta, acione a equipe de IT SERVICES para liberar o acesso a ferramenta via Cloud.
2. Execute os comandos abaixo informando o código da empresa, família e o serviço:
SELECT A.ROTPRO, A.* FROM E012FAM A WHERE CODEMP = YY AND CODFAM = 'XXX'X;
SELECT A.ROTPRO, A.* FROM E075PRO A WHERE CODEMP = YY AND CODPRO = 'XXXX';
3. Verifique o resultado e faça o ajuste;
Importante
Ambos os campos devem ter o mesmo valor.
4. Faça um comando de Update para o ajuste, conforme exemplo abaixo:
UPDATE E075PRO SET ROTPRO = '' WHERE CODEMP =YY AND CODPRO = 'XXXX'