ERP - WebService - Foi encontrado o cliente "XX" com o CNPJ/CPF "XXXXXXXXXXXXXXX" informado. Porém, foi informado o código do cliente "XX" que difere do cliente encontrado. Corrija o código do cliente ou o CNPJ/CPF informado
Incidente
No módulo de cadastros, ao integrar as informações do cliente utilizando o webservice Com.senior.g5.co.ger.cad.clientes é retornada a mensagem: Foi encontrado o cliente "XX" com o CNPJ/CPF "XXXXXXXXXXXXXXX" informado. Porém, foi informado o código do cliente "XX" que difere do cliente encontrado. Corrija o código do cliente ou o CNPJ/CPF informado.
Causa
Esta mensagem é retornada, quando:
- Existem dois ou mais cadastros no ERP com o mesmo CNPJ com a situação inativa e o parâmetro 'CNPJ/CPF/ Nº Ident. Fiscal Cliente Repetido' está definido como 'N-Não' no cadastro da Filial na Tela F070FVE - Cadastros / Filiais / Parâmetros por Gestão / Vendas, Faturamento e Transporte (Parâmetros da Filial para Vendas);
- Existem dois ou mais cadastros no ERP com o mesmo CNPJ com a situação ativa e o parâmetro 'CNPJ/CPF/ Nº Ident. Fiscal Cliente Repetido' está definido como 'N-Não' no cadastro da Filial na Tela F070FVE - Cadastros / Filiais / Parâmetros por Gestão / Vendas, Faturamento e Transporte (Parâmetros da Filial para Vendas);
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Acesse a Tela F070EMP - Cadastros / Empresas / Cadastro (Cadastro de Empresas);
1.1. Acione o botão Par. Dinâmicos no rodapé da Tela;
1.2. Defina no parâmetro EMPRESA.WS.IGNORARINATIVOAOVALIDARDUPLICIDADE como S (Sim):
1.3. Selecione a linha do parâmetro e acione o botão Processar;
2. Entre na tela F070FVE - Cadastros / Filiais / Parâmetros por Gestão / Vendas, Faturamento e Transporte (Parâmetros da Filial para Vendas);
2.1. Altere para 'S-Sim' o parâmetro 'CNPJ/CPF/ Nº Ident. Fiscal Cliente Repetido':
Observação
Para maiores informações sobre o processamento do WebService, consulte a Documentação do WebService Com.senior.g5.co.ger.cad.clientes.