Tecnologia - Atualização - Ocorreu um erro ao iniciar o sistema e a aplicação será finalizada. As causas do problema estão identificadas no botão "Detalhes": A atualização de base de dados não foi executada para esta versão do TBS. Provavelmente a base
Incidente
No módulo ERP, ao tentar acessar, após uma atualização de versão, a seguinte mensagem é apresentada: Ocorreu um erro ao iniciar o sistema e a aplicação será finalizada. As causas do problema estão identificadas no botão "Detalhes": A atualização de base de dados não foi executada para esta versão do TBS. Provavelmente a base foi consistida via CBDS.
Causa
Essa mensagem é apresentada, pois durante a atualização, ocorreu divergência e não foi possível popular a tabela E000CRR que guarda o histórico de versões.
Solução
Para que a mensagem não seja mais apresentada e o acesso ao sistema normalize, siga os passos abaixo:
1. Execute o CBDS;
1.1. Acesse com o usuário da base de dados;
1.2. Entre no menu Ajuda / Sobre a base;
1.3. Verifique a versão do TBS;
2. Acesse a base dados;
2.1. Execute o seguinte comando na base de dados:
SELECT * FROM R999VER
3. Execute o seguinte comando na base de dados, para validar se as versão estão iguais:
SELECT
*
FROM
E000CRR
WHERE
VERAMB = 0
AND VERINO = 0
AND VERBAS = 0
AND CODCRR = '000ATUBS01'
3.1. Altere a versão retornada pelo campo DesCrr para a mesma versão do TBS. O campos DesCrr tem de estar com a versão do tbs, conforme exemplo abaixo:
UPDATE
E000CRR
SET
DESCRR = '[VERSÃO DO TBS] ATUALIZAÇÃO DE BASE UTILIZANDO O PACOTE SAPIENS_INST.BPL DE VERSÃO 5.8.11.58_#15.'
WHERE
VERAMB = 0
AND VERINO = 0
AND VERBAS = 0
AND CODCRR = '000ATUBS01'
3.2.Execute o comando na base de dados.
Atenção
Caso as versões não sejam iguais, atualize o ambiente para a versão mais recente, assim deixando o TBS e base na mesma versão.