TMS – RBT - Recebimento de NF-e via e-mail com autenticação OAUTH2 parou de funcionar
Incidente
O RBT RecebeNFe com e-mail, cuja autenticação é OAUTH2 parou de funcionar.
Causa
Este incidente ocorre pois, existe tokens de autenticação duplicados no banco de dados para o mesmo endereço de e-mail de recebimento.
Solução
Para corrigir o incidente de Falha na Autenticação ou Autenticação Malsucedida, execute as orientações a seguir:
1. No aplicativo de entrada, acesse Utilitários / SQL:
2. No módulo STSQL, realize o Login e marque a opção Resultado Editável;
2.1. Digite o comando abaixo e pressione F5:
SELECT *
FROM SISCFGOAUTH2TOKEN;
2.2. Se houver mais de um registro na coluna NrToken com a mesma conta de e-mail vinculada, apague os Tokens:
3. No módulo CFG, acesse Utilitários / Configurações / Configurações Gerais:
3.1. Acesse a aba Envio de E-mails;
3.2. Informe os dados da conta de Recebimento no Servidor SMTP;
3.3. Informe os dados de Protocolo SSL;
3.4. Clique no botão Teste Configurações SSL:
4. Será apresentada uma tela de login da Microsoft para a geração do Token de autenticação da conta:
5. Após a geração do Token de Autenticação, acesse a guia SPED;
5.1. Informe no campo Recebimento de NF-e os dados que foram cadastrados na aba Envio de E-mails:
6. As operações que utilizam contas de e-mail diferentes para Envio e Recebimento, após configurar a conta de Recebimento na aba SPED, retorne à aba Envio de E-mails e configure a conta de Envio.
Observação: Para casos de Recebimento de NF-e via RBT, revise no Regedit as configurações de TLS e SSL para ficar conforme parâmetros preenchidos no TMS.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.