TECNOLOGIA - eDocs – Não foi possível obter resposta da URL 'https://webservices.envio.esocial.gov.br/servicos/empregador/enviarloteeventos/WsEnviarLoteEventos.svc'. The underlying connection was closed. An unexpected error occurred on a send
Incidente
No módulo do eDocs, ao tentar consultar a URL de consulta da situação do documento e a URL de envio síncrono ou assíncrono de Lote, é apresentada a mensagem: Não foi possível obter resposta da URL 'https://webservices.envio.esocial.gov.br/servicos/empregador/enviarloteeventos/WsEnviarLoteEventos.svc'. The underlying connection was closed. An unexpected error occurred on a send.
Causa
Esta mensagem é apresentada, pois nas configurações de conexão do eDocs o TLS 1.2 não está marcado e/ou não está ativo no Regedit do Windows.
Solução
Para que a mensagem não seja apresentada ao tentar consultar a URL de consulta da situação do documento e a URL de envio síncrono ou assíncrono de Lote, realize os passos a seguir:
Observação: Verifique com a sua equipe de infraestrutura antes de aplicar as configurações abaixo.
-
Verifique se o eDocs está com o TLS 1.2 ativo;
1.1. Acesse o seguinte caminho: Configurações \ Gerais \ Avançado \ Conexão;
1.2. Verifique se a Configuração SSL/TLS está conforme a imagem abaixo: -
Verifique se o servidor está com o TLS 1.2 ativo no Regedit do Windows;
2.1. Abra o Executar do Windows;
2.1.1. Digite 'regedit' e clique em OK.
2.2. Acesse o seguinte caminho: Hkey_Local_Machine \ System \ CurrentControlSet \ Control \ SecurityProviders \ SCHANNEL \ Protocols;
2.3. Expanda o diretório 'TLS 1.2';
2.4. Clique sobre a pasta 'Client', conforme a imagem abaixo:
2.5. Clique duas vezes sobre a chave 'DisableByDefault';
2.5.1. Altere o valor para 0, conforme a imagem abaixo:
2.5.2. Clique em OK;
2.8. Clique duas vezes sobre a chave 'Enabled';
2.8.1. Altere o valor para 1, conforme a imagem abaixo:
2.8.2. Clique em OK; -
Reinicie o servidor para que as alterações sejam aplicadas.