TMS - CTRB/RPA - Documentos Emitidos apresentam a mensagem 'Registro já existe' na integração com HCM
Incidente
No módulo Freteiros, CTRBs emitidos não integraram com o HCM e apresentam a mensagem 'Integração da Carta Frete 204895 - Erro: Ocorreu um erro ao executar o serviço "AP - Terceiros - Pagtos Física": Problemas na inclusão. Registro já existe.'
Causa
Este incidente ocorre, pois no ato da integração inicial, apresentou erro de comunicação com o HCM ou com o Webservices do HCM e ao tentar reenviar o documento apresenta a mensagem que o registro já existe.
Solução
Para realizar a parametrização, siga os passos abaixo:
1. Acesse o STSQL e rode o comando de update para deixar o campo cdseqhcm nulo para reintegrar com sucesso:
UPDATE FTRCFT SET CDSEQHCM = NULL WHERE NRCGCCPFPROPR = 'CGCCPF DO PROPRIETÁRIO' AND CDEMPRESA = 1 AND CDCARTAFRETE = 204895
2. Abra o módulo FTR e selecione a carta frete que ocorreu a falha na integração:
3. Vá na guia Integração HCM e clique em Reenviar Integração:
4. Consulta na guia integração se o documento foi integrado com sucesso.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.