TMS - Aplicativo de Entrada - Lentidão no sistema ou Lock na base
Incidente
Na utilização do sistema é apresentada lentidão excessiva ou travamento.
Causa
Este incidente ocorre pois, pode haver um travamento de comando na base de dados do sistema.
Solução
Para verificar o Lock em base, execute os passos a seguir:
1. No aplicativo de Entrada, acesse Utilitários / SQL;
1.1. Realize o login no STSQL:
2. Execute o comando a seguir para verificação dos comandos que estiverem em execução ou travados no sistema: SELECT SP.SPID ID, DB_NAME(DBID) DBNAME, SP.BLOCKED ID_BLOQ, SP.OPEN_TRAN TRAN_ABER, (SELECT CAST(TEXT AS VARCHAR(4000)) FROM SYS.DM_EXEC_SQL_TEXT(SP.SQL_HANDLE)) COMMANDO , SP.WAITTIME/1000 [TEMPO SEG.] , (SELECT CAST([TEXT] AS VARCHAR(8000)) FROM ::FN_GET_SQL((SELECT TOP 1 [SQL_HANDLE] FROM SYS.SYSPROCESSES WHERE SPID = SP.BLOCKED))) SQL_BLOQUEIO , SP.STATUS [STATUS] , SP.HOSTNAME MAQUINA , SP.[PROGRAM_NAME] , SP.LOGINAME FROM SYS.SYSPROCESSES SP WHERE STATUS <> 'SLEEPING' AND SP.SPID > 50 ORDER BY 6 DESC, PHYSICAL_IO DESC:
3. Para finalizar a atividade do ID_BLOQ que está travado informe o comando KILL XX (Número do ID_BLOQ desejado) e pressione F5:
4. Após finalizar o processo, acesse o sistema novamente para prosseguimento das atividades na rotina desejada.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.