Globaltec UAU – Boleto Online – Atenção!!! Os boletos abaixo não foram registrados, segue abaixo o motivo retornado pelo banco
Incidente
No ERP UAU, módulo Vendas, ao emitir boleto online do Banco Itaú é apresentada a mensagem: Atenção!!! Os boletos abaixo não foram registrados, segue abaixo o motivo retornado pelo banco. Para maiores esclarecimentos, consulte o guia de integração (MANUAL TÉCNICO E LAYOUT REGISTRO ONLINE DE BOLETOS DE COBRANÇA ITAÚ CNAB 400)
Banco: XX Nosso número: XXXXXXXX
Emp: XX Obra: XX Núm. venda: XX Num. parc.: X Tipo parc.: X
Erro ao registrar boleto. A mensagem retornada foi: A conexão subjacente estava fechada: Não foi possível estabelecer relação de confiança para o canal seguro de SSL/TLS.
Causa
Esta mensagem é apresentada, pois alguma das informações repassadas pelo banco e incluídas na configuração de cobrança bancária estão incorretas, tais como: Registro on-line, URL do autorizador, URL de registro, Cliente Secret, Cliente ID e Itaú chave.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. No módulo Vendas, acesse Utilitários / Configuração de cobrança bancária:
2. Na opção Config., selecione a Empresa / Clique em buscar / Selecione a configuração de cobrança bancária / Dê um duplo clique:
3. Confira as informações preenchidas na Manutenção do padrão de cobrança, faça a alteração necessária / Clique em Gravar:
Observações:
- A URL de registro, URL do autorizador, Cliente ID, Cliente Secret e Itaú chave é fornecida pelo banco Itaú, normalmente através de e-mail e do manual técnico Layout.
- Importante confirmar se no contrato junto ao banco possui a contratação do serviço de boleto online.
- O Itaú já liberou uma nova versão de layout para boleto online, v2, porém o UAU está funcionando com o v1. Quando for solicitar o contrato do boleto online junto ao banco é necessário solicitar que seja efetivado no layout da v1.