ERP – Produtos e Serviços – Não foi possível encontrar na tabela E075PRO o(s) valor(es) "X; " no(s) campo(s) "CodEmp;CodPro"
Incidente
No módulo de Cadastros, ao tentar consultar ou cadastrar um produto, é apresentada a mensagem: Não foi possível encontrar na tabela E075PRO o(s) valor(es) "X; " no(s) campo(s) "CodEmp;CodPro".
Causa
Esta mensagem é apresentada, pois algum registro na tabela E075PRO está com o campo Codpro = "" (vazio).
Solução
Para que a mensagem não seja apresentada ao efetuar a consulta ou cadastro de um produto, realize os passos a seguir:
1. Acesse uma ferramenta de banco de dados e execute os seguintes comandos na ordem abaixo substituindo o parâmetro X pelo código da empresa em que a mensagem está sendo apresentada:
SELECT * FROM E075DER
WHERE CODEMP = X AND CODPRO = ' ';
DELETE FROM E075DER
WHERE CODEMP = X AND CODPRO = ' ';
SELECT * FROM E075OBS
WHERE CODEMP = X AND CODPRO = ' ';
DELETE FROM E075OBS
WHERE CODEMP = X AND CODPRO = ' ';
SELECT * FROM E075PRO
WHERE CODEMP = X AND CODPRO = ' ';
DELETE FROM E075PRO
WHERE CODEMP = X AND CODPRO = ' ';
Observação:
Antes de executar o comando DELETE, realize um SELECT nas tabelas para verificar os registros inconsistentes.
Caso tenha TI interna, solicite apoio para executar os comandos.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.